Hi. I'm new to Slack (and Docker. And quite a few ...
# openlane
Hi. I'm new to Slack (and Docker. And quite a few other things actually... :-/) so I'm not sure if this is the best place to post this... Anyway. I've installed Docker (on a fresh Xubuntu 20.04 in accordance with the docs.docker.com/engine/install/ubuntu instructions) except that I didn't add myself to the docker group (with usermod) 😞 Then I followed the github.com/efabless/open/README.md instructions (except I did sudo make ...) There were loads of errors and warnings and 100s (?) of thousands of lines of output, and then after a while it seemed to freeze. After 1/2 an hour or so I killed it off. Then I just tried 'make test' -- and it worked! (But some of the regression tests failed). Then, realising that some things just take a while (suggestion: add a warning in the README.md to be patient, e.g wait an hour or so?), I decided to delete the openlane directory and start again (having added myself to the docker group). It says my docker image/container/whatever is up to date. How do I delete it or change ownership/permissions? While it appeared frozen, I did an 'lsof' ('top' was showing 100% processor usage for magic, but I wanted to see if anything was actually happening). There were loads of "magicdnul [...snip...] /usr/lib64/libc-2.17.so (stat: No such file or directory)" entries for libc, libGL, libX11 etc. Is this normal? Isn't the point of Docker that there should be no dependency/library issues?
Actually there is no "sudo" usage in README.md, just run these, not less not much:
Copy code
git clone <https://github.com/efabless/openlane.git>
    cd openlane/
    make openlane
    # Default PDK_ROOT is $(pwd)/pdks. If you want to install the PDK at a differnt location, uncomment the next line.
    #export PDK_ROOT=<absolute path to where skywater-pdk and open_pdks will reside>
    make pdk
    make test # This is to test that the flow and the pdk were properly installed
You can change the file ownership in linux with this command, you can also search these type of things at askubuntu.com, superuser.com
Copy code
sudo chown username:username -R folder
Thanks for the quick reply, but I know there was no sudo. I was just saying what I actually did, to explain the situation. Also, I'm fine with unix commands and the shell 🙂 I just don't know where the Docker containers are. (Actually, I've found out they're in /var/lib/docker/overlay2 -- but which one? The names are not helpful...
I see, so you can remove the docker containers you have created with wrong permissions with this:
docker rm $(docker ps -aq)
Then create normally again.