<@U017X0NM2E7>, <@U01E2KKE4SH>, <@U016EM8L91B>: FY...
# sky130
@User, @User, @User: FYI, I was able to install the IOs (and thus update openlane:develop commits) yesterday. If you're using the openlane:develop Makefile you won't have to change anything. Just export PDK_ROOT and run
and that's that (They are always installed beside whatever std_cell_library you choose). So, I used the latest open_pdks and the latest skywater-pdk without facing any installation issues. If you're running this outside of the openlane makefile setup, then make sure you update the right submodule
and there is no need to run
make timing
since there are no liberty files for the IOs (although it won't complain if you ran it but it won't produce anything). There shouldn't be any changes in the way you normally run open_pdks. To be exact, these are the versions I used: https://github.com/RTimothyEdwards/open_pdks/tree/6cdeb7a2c5a90339512ee2f08948a8a5895626b8 https://github.com/google/skywater-pdk/tree/1ce480d61120895462adc03df617d39de7a0f76e However, I don't see anything that would prevent the same result using the latest versions (1 extra commit in each repo). Also, I still haven't tested the resulting IOs, just made sure that everything is produced in the right place.
Thanks, I get a few errors on macos on
which I'll post up soon if I can't solve them
@Mitch Bailey’s suggestion on the
error solved one isssue, working through another error now
Copy code
set -f ; ../common/foundry_install.py -std_format -source /Users/dan.rodrigues/hw/skywater-pdk/libraries -target `pwd`/sky130A \
		-ngspice sky130_fd_pr/latest/models/* \
		filter=custom/scripts/rename_models.py \
		|& tee -a sky130A_install.log
bash: -c: line 0: syntax error near unexpected token `&'
I don't remember getting this error before, I'll remove the
as a quick first attempt
ok, updating the makefiles to 1. avoid checking out the open_pdks commit 2. Removing the
which neither bash or zsh on macos tolerate apparently Then
copied files to /sky130A as desired. Onto diagnosing sim erros in the shuttle now..
@drr I remember running into this before too.
doesn't seem to work on macos. I found this, though, so you should be able to replace it with
2>&1 |
which I think I did previously and it worked.
Copy code
If '|&’ is used, command1’s standard error, in addition to its standard output, is connected to command2’s standard input through the pipe; it is shorthand for 2>&1 |. This implicit redirection of the standard error to the standard output is performed after any redirections specified by the command.
Or you could run
make build-pdk
inside docker which is Linux and understands`|&`.
which is what I ended up doing instead of fixing the make files with every pull.
I might do that for future runs, I've only been using the docker to do
./flow-tcl -design
runs so far
@drr: You can also run
make build-pdk
from within the openlane docker (which already has magic). I do this here.
👍 1