Hi, can anyone help... i tried to use the mim_cap ...
# sky130
Hi, can anyone help... i tried to use the mim_cap model supported with the technology and i got this error? there are parameters defined inside the model but the values are not found in the supported picture is an trivial bench_test and still the error found any help?
Can you post the netlist?
**.subckt untitled R1 in out 1k m=1 V1 in 0 3 XC1 out 0 sky130_fd_pr__cap_mim_m3_2 W=1 L=1 MF=1 ** begin user architecture code .include ~/mabrains/skywater-pdk/libraries/sky130_fd_pr/latest/models/capacitors/sky130_fd_pr__model__cap_mim.model.spice .op .print V(in) V(out) .save all ** end user architecture code **.ends .end
I would recommend trying with:
.lib ~/mabrains/skywater-pdk/libraries/sky130_fd_pr/models/sky130.lib.spice tt
Instead of the include line
It will take longer though, so expect to wait 40 seconds
ok i will try
thanks very much
If that works you can use:
.include ~/mabrains/skywater-pdk/libraries/sky130_fd_pr/models/corners/tt.spice
Which will be a bit faster
It's not a problem
@Haseeb Ahmad I was able to simulate with no problem, I think you must include the top level model file or the 'tt' corner as @yrrapt suggested. There are lot of parameners defined all around, if you include only the capacitor file lot of definitions will be missing. Also do not specify m4_dw as instance parameter, it is not needed (it is a model parameter).