Hi, I am having issues doing full PEX extraction. ...
# analog-design
Hi, I am having issues doing full PEX extraction. When looking at the generated PEX it contains additional pin "error" which makes it impossible to simulate the .spice because I don't know where error pins comes from and what to connect to it. Commands to generate PEX looks like this: gds read ../gds/my_nand.GDS load my_nand select top cell extract all ext2sim labels on ext2sim shell mv my_nand.ext.nodes my_nand.nodes extresist all ext2spice cthresh 0 ext2spice rthresh 0 ext2spice subcircuit on ext2spice extresist on ext2spice -f ngspice -o ../netgen/my_nand.pex.spice Providing relevant files here. Can somebody help me?
Make sure you have an updated version of magic. I worked a lot on the extresist method recently (as in a few months ago) and I have solved all those issues. The only remaining issue is that extresist does not work on hierarchical layouts, so you will need to flatten the layout first, then run extract/ext2sim/extresist/ext2spice on it.
Oops... I just realized I have been using .145 version of magic from openlane docker. My mistake, thanks for suggestion!