Another issue, when I run a design involved a pnp ...
# analog-design
Another issue, when I run a design involved a pnp transistor, i obtain the following error in the ngspice window: "unknown subckt:xq1 net1 e1 sky130_fd_pr__pnp_05v5 w3p40l3p40
Did you import/include the sky130 spice library?
Is it possible to share the netlist?
which one?
@User @User
** sch_path: /home/ahmad/open_pdks/sky130/sky130A/ **.subckt test_bipolar XQ1 net2 net1 E1 sky130_fd_pr__pnp_05v5_W3p40L3p40 Vc1 net2 0 0 .save i(vc1) Vb1 net1 0 0 .save i(vb1) I0 0 net3 0 Ve1 net3 E1 0 .save i(ve1) ** begin user architecture code .control save all dc i0 5n 5u 0.05u * tran 1n 2u plot vc1#branch / vb1#branch plot e1 .endc ** opencircuitdesign pdks install .lib /home/ahmad/OpenLane/pdks/skywater-pdk/libraries/sky130_fd_pr/latest/models/sky130.lib.spice tt *.lib /home/ahmad/open_pdks/sky130/sky130A/ tt *.lib /home/ahmad/open_pdks/sky130/sky130A/ * ngspice initialization for sky130 * assert BSIM compatibility mode with nf vs. W set ngbehavior=hsa * nomodcheck speeds up loading time set ng_nomodcheck ** end user architecture code **.ends .end
I have no idea about this. I think @User can help you much more.
I have run this test right now and it works. You need to use open_pdks install, not the skywater-pdk root. Try to use the commented .lib statement:
.lib /home/ahmad/open_pdks/sky130/sky130A/ tt
@Stefan Schippers I have the same error, and so change the route does not work