https://open-source-silicon.dev logo
#openlane
Title
# openlane
e

Ernest Seah

07/28/2020, 12:33 PM
Thanks. I'm running Ubuntu 20.04 on WSL2, is the edit made to grub in Ubuntu or in Centos? I tried "sudo nano /etc/default/grub" followed by "sudo update-grub" in Ubuntu and rebooted but am still seeing the same error. I'm a Docker noob and will need help if the edit needs to be made within Centos. Thanks again.
a

Ahmed Ghazy

07/28/2020, 1:05 PM
Could you elaborate on which modification exactly you've done to your
/etc/default/grub
file?
e

Ernest Seah

07/28/2020, 1:21 PM
This one. As @Tim Edwards pointed out in issue #9, given that WSL doesn't actually use GRUB, this workaround doesn't seem to work for me. I'll probably just restart the install on a new dedicated machine. I just wish I'd known before spending all that time getting to this point:P
t

Tim Edwards

07/28/2020, 2:34 PM
@Ernest Seah: See my comment in the openlane Issue; have you tried switching to centos7 in the dockerfile? It has some issues but it may be possible to work around them.
e

Ernest Seah

07/28/2020, 2:35 PM
I did, but got stuck here when my day job distracted me:P Will look into it more later
e

Ernest Seah

07/28/2020, 6:23 PM
@sto Thanks! That seems to have done the trick. I left it running over lunchtime and it seems to have completed all 22 steps with WSL2/Ubuntu 20.04/Centos 6
Got a bunch of permission denied errors when creating directory but don't have the password for superuser. I'm guessing something else is wrong since nobody else seems to be asking for it.
a

Ahmed Ghazy

07/28/2020, 7:05 PM
You shouldn't be running the container as root. The proper solution is to add your user to the docker group so you can do
docker run
without
sudo
. If you do
groups
and "docker" is not one of them, you need to create the docker group using:
sudo groupadd docker
. Then you need to add youself to it using:
Copy code
sudo usermod -aG docker $USER
Note that you need to log out and re-log in for this to take effect (or - not recommended - use
newgrp docker
if you don't want to log out and back in again now).
e

Ernest Seah

07/29/2020, 1:50 AM
Thanks. I tried that but am still getting the same permission denied error. What else should I check?
should the sky130A directory be under the skywater-pdk directory?
I deleted everything and did a from scratch install. Looks to be working now.
👍 1
4 Views