I just tried to switch openlane from master to dev...
# openlane
I just tried to switch openlane from master to develop branch, and got this output when I tried to build the docker:
@Philipp Gühring: I'm not sure why you are trying to rebuild the standalone version of replace since we no longer use this one in the flow (we keep it around because it's useful in some rare cases in the interactive scripts). However, we use the replace version inside the openroad_app. Which you don't have to rebuild as well unless you want to change the commit hash. All you should do is run
make merge
I didnt tried to build replace, I just tried to build the docker for openlane, since I tried to switch from master to develop branch of openlane. $ make merge make: * No rule to make target 'tar/replace.tar.gz', needed by 'tar/openroad_tools.tar.gz'. Stop.
@Philipp Gühring: Can you check with
git status
in case the file was accidentally deleted? Then
git checkout -- .
Yes, it got accidently deleted. Strange, I dont remember having deleted anything myself.
Ok, building the develop branch worked now.