I have a fresh clone of caravel_user_project, I ra...
# openlane
I have a fresh clone of caravel_user_project, I ran make install but then make pdk fails with this:
Copy code
$ make pdk
export CARAVEL_ROOT=/home/mrg/caravel_user_project/caravel && make -f /home/mrg/caravel_user_project/caravel/Makefile pdk
make[1]: Entering directory '/home/mrg/caravel_user_project'
cd /software/PDKs/skywater-pdk && \
        git checkout main && git pull && \
        git checkout -qf bb2f842ac8d1b750677ca25bc71fb312859edb82
M       libraries/sky130_fd_pr/latest
Already on 'main'
Your branch is behind 'origin/main' by 16 commits, and can be fast-forwarded.
  (use "git pull" to update your local branch)
Fetching submodule libraries/sky130_fd_io/latest
Could not access submodule 'third_party/make-env'
Fetching submodule libraries/sky130_fd_sc_hvl/latest
make[1]: *** [/home/mrg/caravel_user_project/caravel/Makefile:462: skywater-pdk] Error 1
make[1]: Leaving directory '/home/mrg/caravel_user_project'
make: *** [Makefile:40: pdk] Error 2
What am I missing?
@User Are you willing to delete your pdk directory and try again? I think I remember some people having the same problem a while back. I believe a clean install of the pdks fixed it.
I'll try that.