https://open-source-silicon.dev logo
#openlane
Title
# openlane
d

Darío San Martín Molina

01/22/2022, 1:10 PM
Hi, I'm seeing strange beheviour when running a simple LVS comparison with netgen (from @User sky130 physical verification workshop). I have 2 very simple netlists (see attached), initially both netlists are exactly the same, so when I run netgen lvs I get a match as expected (case 1 in the attachment, so far so good). Then I change one port on one of the instances in netlistA, now the netlists are different however when I run netgen lvs it still shows a match (case 2 in the attachment), not sure why. I also tried a 3rd case where I do another simple change in the netlistA on a different port, and this time netgen lvs does catch the mismatch. It's a simple test so I don't understand what I'm missing here. Can anyone see why it doesn't flag the mismatch in case 2? PS.: Btw this happens whether I run netgen lvs in batch mode or from the gui, whether I quit and restart netgen or not, and I have already tried "reinitialize" command on netgen gui, without success.
t

Tim Edwards

01/22/2022, 3:14 PM
When I run your case 2, it shows a mismatch. What version of netgen are you running?
Also, is there a "setup.tcl" file in the directory that might affect how netgen runs?
d

Darío San Martín Molina

01/22/2022, 3:41 PM
I just updated netgen to latest version building from source and it got fixed, thanks for the reply