Hi everyone I was trying to update my openlane. Wh...
# openlane
Hi everyone I was trying to update my openlane. When i run
make pull -openlane
I'm facing with error :
post full log
Copy code
Cannot determine git branch. Please specify OPENLANE_IMAGE_NAME manually.
Full output: error: unknown option `show-current'
usage: git branch [<options>] [-r | -a] [--merged | --no-merged]
   or: git branch [<options>] [-l] [-f] <branch-name> [<start-point>]
   or: git branch [<options>] [-r] (-d | -D) <branch-name>...
   or: git branch [<options>] (-m | -M) [<old-branch>] <new-branch>
   or: git branch [<options>] (-c | -C) [<old-branch>] <new-branch>
   or: git branch [<options>] [-r | -a] [--points-at]
   or: git branch [<options>] [-r | -a] [--format]

Generic options
    -v, --verbose         show hash and subject, give twice for upstream branch
    -q, --quiet           suppress informational messages
    -t, --track           set up tracking mode (see git-pull(1))
    -u, --set-upstream-to <upstream>
                          change the upstream info
    --unset-upstream      Unset the upstream info
    --color[=<when>]      use colored output
    -r, --remotes         act on remote-tracking branches
    --contains <commit>   print only branches that contain the commit
    --no-contains <commit>
                          print only branches that don't contain the commit
    --abbrev[=<n>]        use <n> digits to display SHA-1s

Specific git-branch actions:
    -a, --all             list both remote-tracking and local branches
    -d, --delete          delete fully merged branch
    -D                    delete branch (even if not merged)
    -m, --move            move/rename a branch and its reflog
    -M                    move/rename a branch, even if target exists
    -c, --copy            copy a branch and its reflog
    -C                    copy a branch, even if target exists
    --list                list branch names
    -l, --create-reflog   create the branch's reflog
    --edit-description    edit the description for the branch
    -f, --force           force creation, move/rename, deletion
    --merged <commit>     print only branches that are merged
    --no-merged <commit>  print only branches that are not merged
    --column[=<style>]    list branches in columns
    --sort <key>          field name to sort on
    --points-at <object>  print only branches of the object
    -i, --ignore-case     sorting and filtering are case insensitive
    --format <format>     format to use for the output
make: *** No rule to make target 'pull'.  Stop.
I think Git version is too old
git --version
what id the output? it needs to be newer than 2.35
git version 2.17.1
how can i update it ?
Update as per prerequisites and still fail Try below format:
export OPENLANE_IMAGE_NAME=2022.03.15_02.27.26
&& make pull-openlane
its depends on OS. Check in your browser
Copy code
sudo apt-get update
sudo apt-get install git
For Ubuntu For Centos sudo yum update sudo yum install git
yes i updated but it says latest version is 2.17.1 for ubuntu 18.04. should i update the OS?
download git 2.35 and above version and install manually
You can just build git from source, or manually use tag from git log
Unlikely to be git imo
Much more likely a docker name issue
I would just delete it and do make openlane from caravel_user_project
@User We faced the same issue in issue 963. I added git version requirement in readme, because of this exact reason.
😬 1
Maybe I should add a warning in caravel for git version being too old?
Updating git solved it. Thanks btw.
🙌 1