Hello everyone As, I want to use magic tool for c...
# magic
Hello everyone As, I want to use magic tool for creating the layout using sky130 tech but can someone please tell me that where should I open the magic and how to open and interface the magic with sky 130technology ?
As, I have followed the steps to open sky130A tech file in magic that I have copied the sky130A.magicrc file inside the vsdflow/work/tools/magic8.3/magic_sky130_simukation folder and rename it with .magicrc then, run " magic " command inside the same terminal under same directory , so, it's showing this error . Where this magic_sky130_simulation folder is make by me inside this guevn directory as specified above . Can anyone pleas tell me how to solve this error ? @Tim Edwards sir please help me
It is pointing to a file
that apparently does not exist. For an installation of open_pdks, the
file pointed to by the associated
file should be in the same directory. If you got the
file from the
folder, then the tech file should not be in
So, sir what should I do now ? I am not able to understand that now how to solve this problem of different directory ?
magic -T ../../$PDK/long/path/sky130A.tech user_proj_example/runs/user_proj_example/results/magic/user_proj_example.drc.mag
magic -rcfile $PDK_ROOT/sky130A/libs.tech/magic/sky130A.magicrc
After executing this last command it's showing this error Segmentation fault(core dumped) and the magic is opening and closing automatically and after that this error come segmentation error and magic closes by itself
What does magic output if you do
magic --version
Sir, it's 8.3.50
You are 316 revisions out of date with the current version, which is probably why it is segfaulting.
The release date of 8.3.50 was August 12, 2020.
So, sir should I update it now ?
Yes, definitely.
Sir, when I am downloading again the magic tool ,then while executing the make command it's showing this error
No libstdc++? You need to install a basic compiling environment, like
apt get build-essential
Sir, still same error persist
@vanshika tanwar for ubuntu just run following:
Copy code
sudo apt-get update
sudo apt-get remove magic
sudo apt-get install magic
I have tried all these steps also, still magic 8.3.50 is doneloading and I have tried downloading it from scratch still it's showing error while opening the magic with sky130A technology
Sir, I have tried uninstalling and reinstalling or again installing it again and again but still it's showing same error what should I do now ?
Can you please suggest me the all installation steps ? As , I have tried installing using that make command also, and using this sudo apt-get install magic command also, but still same error persist
apt install libstdc++
. Apparently build-essential doesn't include it. Using
apt install magic
will just get you a very outdated version. Don't use it.
Sir, it's installed and also opens with sky130 technology when I have downloaded from this link