Hi, just tried running `make timing` in the PDK re...
# sky130
Hi, just tried running
make timing
in the PDK repo and got this conda error:
Copy code
Collecting package metadata (repodata.json): done
Solving environment: failed

  - netlistsvg
  - yosys
I don’t have experience with conda but can see these listed in environment.yml (presumably from the “symbiflow” channel?). I am on macos if there's a platform specific issue I’m not aware of. I already have yosys and the rest of the OSS FPGA toolchain in
but would rather stick to the version offered here to avoid any surprises
@drr make in the skywater-pdk gave me the same error. I think the reason was that I was installing on a mac and there was any netlistsvg or yosys package available. What I did was to comment out those 2 lines in the envrionment.yml (filename maybe slightly different) file. Are netlistsvg and yosys actually needed for skywater-pdk installation?
Thanks @User, I just got rid of those two and "make timing" works fine. I wonder if the workflow depends on the yosys in that particular env at a later point though Did you have any luck building magic on macOS? I got a successful configure log (all prerequisites satisfied), build and install and either * It segfaults immediately on startup using "-d OGL/X11" * Or, it immediately exits and shows no window using "-d XR/CAIRO" Interested to hear if any macos users had any luck with the workflow (macos Catalina here)
No couldn't get magic to work on macos. Had to use docker for with noconsole. Run the magic GUI on Windows (downloaded binary). I'll share the setup flow I used to run openlane on macos after I return home.
yes, works fine on mac, but won’t work with Quartz, so you need to install x11 and fix the scripts to build against it.
What I did to install openlane on macos Catalina. (see https://github.com/efabless/openlane) 1. Get openlane
Copy code
git clone git@github.com:efabless/openlane --branch rc4
    cd openlane
    docker pull efabless/openlane:rc4
There is a Makefile in openlane, and if everything is installed, make in openlane will download and install
. However, git didn't work inside docker, but the scripts to build the libraries only worked in docker. 2.
export PDK_ROOT=<absolute path to where skywater-pdk and open_pdks will reside>
3. In the openlane directory,
Copy code
make skywater-pdk 
make open_pdks
This should clone the correct github repos. 4. In the
directory, delete the following lines from
Copy code
- netlistsvg
- yosys
5. Back in the openlane directory
make skywater-library
6. Start docker
Copy code
export IMAGE_NAME=efabless/openlane:rc4
    docker run -it -v $(pwd):/openLANE_flow -v $PDK_ROOT:$PDK_ROOT -e PDK_ROOT=$PDK_ROOT -u $(id -u $USER):$(id -g $USER) $IMAGE_NAME
make build-pdk
8. Once everythings completes, you should be able to run the sample
Copy code
./flow.tcl -design spm
Step 7 should probably be
cd openlane; make build-pdk
Thanks for the detailed steps, much appreciated
Dear @Mitch Bailey I am using Mac OS Catalina.
I tried all the 7 steps.
I am getting this error. Please help me in correcting this.. Thanks in advance.
what's your PDK_ROOT set to? what command did you execute to get this error?
@Mitch Bailey Thank you...Got it.
But am not using MAGIC layout. Am using KL layout. I interested to know how to see the placed standard cells in the layout..
Can KL layout view the GDS file?
Yes @Mitch Bailey. Please see the layout view from KL layout of spm.gds.
@b.srinath Srinath So everything's working like you want now? No problems?
Dear @Mitch Bailey, I have doubts. Can I see macros in the layout. ?
How to see timing reports and power reports?
Thanks in advance.
@b.srinath Srinath I don't think there are any macros in the spm design. Maybe in a bigger design, but I couldn't tell you which one. I know nothing about timing or power reports. sorry.
thank you @Mitch Bailey .
Did you have any luck building magic on macOS?
Interested to hear if any macos users had any luck with the workflow (macos Catalina here)
Belated reply on this point: I just got the
docker image version of magic working with XQuartz afaict fine, by installing some fonts and setting up DISPLAY forwarding. More information in links:
✔️ 1
Cloning into 'openlane'... Warning: Permanently added the RSA host key for IP address '' to the list of known hosts. git@github.com: Permission denied (publickey). fatal: Could not read from remote repository. Please make sure you have the correct access rights and the repository exists.
Tried this command and for the error git clone git@github.com:efabless/openlane --branch rc4