Hi everyone! Is this the right place to ask questi...
# sky130
Hi everyone! Is this the right place to ask questions about OpenLane? I am absolutely new and the number of projects involed in this is overwhelming. Nevertheless, I have a problem with OpenLane and building a VERY small example. It fails with an error message during "Generating PDN" process. The log is attached. The two core error messages are "Error: cannot open '/.openroad'." and "Unexpected error: can't read "stripe_locs(met4,GROUND)": no such element in array". I tried the process using these two guides:


https://inst.eecs.berkeley.edu/~cs250/fa20/labs/lab1/ Both fail with the same error. However, the "make test" worked flawlessly. Any suggestions?
I analyzed the errors about /.openroad and /.sta and sent bugreports to openroad and openlane and both agreed that you can ignore them and will remove them soon. The idea of those errors is that openroad offers a config file in ˜/.openroad but there are no users in the docker container so $HOME in the docker container is / and those user-specific configurations for openroad are not used by openlane.
I havent seen the stripe_locs error before, I guess you have to check the power/ground grid configuration for that.
Thanks for your effort. I solved the problem, it was a mistake in my veilog code. It's quite a strange error message for a syntax error...
But it works now 🙂