https://open-source-silicon.dev logo
#sky130
Title
# sky130
d

Domagoj Tomić

08/25/2021, 11:00 AM
Hi everyone! I have installed the PDK and necessary tools according to the instructions on https://github.com/The-OpenROAD-Project/OpenLane Everything worked fine, including the regression_test, but I'm not able to open any of the GUI tools, for ex. Magic outputs: "Application initialization failed: couldn't connect to display ":0" No protocol specified" and KLayout: "No protocol specified Warning: klayout: cannot connect to X server :0", this is after trying many docker starting options in makefile. Does anyone know a fix to this? I've tried setting the DISPLAY variable to :0, :1, unix:1 and unix:0.0, the same message appears, on localhost, "echo $DISPLAY" returns ":0".
m

Mitch Bailey

08/25/2021, 12:40 PM
@Domagoj Tomić I haven't been able to run any GUI programs in docker, but it looks like this article explains how. Please let me know if you get something to work. https://www.cloudsavvyit.com/10520/how-to-run-gui-applications-in-a-docker-container/
👍 1
✔️ 1
a

Arman Avetisyan

08/25/2021, 8:35 PM
I use this command: docker run -it --rm -v $PWD:/openLANE_flow \ -v $PDK_ROOT:$PDK_ROOT \ -e PDK_ROOT=$PDK_ROOT \ -v /tmp/.X11-unix:/tmp/.X11-unix \ -e DISPLAY=unix$DISPLAY \ -e OPEN_PDKS_COMMIT=$OPEN_PDKS_COMMIT \ -e SKYWATER_COMMIT=$SKYWATER_COMMIT \ -u $(id -u $USER):$(id -g $USER) \ $IMAGE_NAME Replace IMAGE_NAME with docker image you want to use
👍 1
d

Domagoj Tomić

08/27/2021, 11:57 PM
thank you for your help, @Mitch Bailey I have tried your solution and it works! 🙂
👍 1
5 Views