https://open-source-silicon.dev logo
#openlane
Title
# openlane
v

Vienna S.

05/11/2021, 1:34 AM
Hello! Does anyone know what might cause this error
ePlAce diverged at initial iteration
? I see the github repo about the RePlAce tool, but I'm not sure what causes an error in this step of the openlane placement process. (Error screenshot in comments)
openlane_adc_replace_diverged.png
m

Matt Liberty

05/11/2021, 5:17 PM
The message has been updated to "Re-run with a smaller init_density_penalty value". The default value is 0.00008
Is this a very small design? I've seen it happen sometimes in that case. If you can share the design you can file an issue at https://github.com/The-OpenROAD-Project/OpenROAD/issues
v

Vienna S.

05/11/2021, 5:39 PM
Thanks for your advice! I tried setting
INIT_DENSITY_PENALTY
to the minimum value 1e-6, but the error still persists. It is a pretty small design, and I used the same config parameters I've used for small designs in the past (from this page https://github.com/efabless/openlane/wiki#how-to-add-a-small-design)
If tuning a few more parameters doesn't work I'll file an issue!
m

Matt Liberty

05/11/2021, 5:40 PM
You might try -skip_initial_place
v

Vienna S.

05/11/2021, 5:44 PM
Like this?
./flow.tcl -design digADC -skip_initial_place
Or in the config file?
m

Matt Liberty

05/11/2021, 5:46 PM
I think the control in openlane is PL_SKIP_INITIAL_PLACEMENT
I'm not an openlane expert
v

Vienna S.

05/11/2021, 5:48 PM
Oh thank you I see! I'd just seen the doc about skip_initial_place on the openroad page
I'll give this a try
Hmm I tried setting
PL_SKIP_INITIAL_PLACEMENT
to 1 (instead of the default 0) and that didn't fix it
m

Matt Liberty

05/13/2021, 12:07 AM
Can you put the design in a github issue and I can take a look?
v

Vienna S.

06/02/2021, 6:41 PM
Hi @Matt Liberty, sorry for the late reply! I took a break at the end of the semester to travel home. If you're still willing to take a look at this, I just opened an issue here https://github.com/The-OpenROAD-Project/OpenROAD/issues/703