https://open-source-silicon.dev logo
#openroad
Title
# openroad
t

Tianyu Wei

09/01/2021, 4:38 PM
Hi, everyone. I am trying to install OpenROAD on CentOS 7. I referred to the readme file on github and ran`./etc/DependencyInstaller.sh -dev` (there seems to be a "[elopment]" at the end of the command, but I don't know what it means so I just have it removed) for the dependencies. When I tried to compile the project with
cmake3 ..
, an error occurred: -- The CXX compiler identification is GNU 4.8.5 -- Check for working CXX compiler: /usr/bin/c++ -- Check for working CXX compiler: /usr/bin/c++ - works -- Detecting CXX compiler ABI info -- Detecting CXX compiler ABI info - done -- Detecting CXX compile features -- Detecting CXX compile features - done -- OpenROAD version: 1 -- OpenROAD git sha: 527cd5d8e82308baa1a46265c1338e6c1757858f -- System name: Linux -- Compiler: GNU 4.8.5 -- Build type: RELEASE -- Install prefix: /usr/local -- TCL library: /usr/lib64/libtcl.so -- TCL header: /usr/include/tcl.h -- Found SWIG: /usr/bin/swig (found suitable version "3.0.12", minimum required is "3.0") -- Found Boost: /usr/include (found version "1.53.0") -- Found Python3: /usr/lib64/libpython3.6m.so (found version "3.6.8") found components: Development -- Found ZLIB: /usr/lib64/libz.so (found version "1.2.7") CMake Error at src/CMakeLists.txt:107 (find_package): By not providing "Findspdlog.cmake" in CMAKE_MODULE_PATH this project has asked CMake to find a package configuration file provided by "spdlog", but CMake did not find one. Could not find a package configuration file provided by "spdlog" with any of the following names: spdlogConfig.cmake spdlog-config.cmake Add the installation prefix of "spdlog" to CMAKE_PREFIX_PATH or set "spdlog_DIR" to a directory containing one of the above files. If "spdlog" provides a separate development package or SDK, be sure it has been installed. -- Configuring incomplete, errors occurred! See also "/home/weitianyu/OpenROAD/build/CMakeFiles/CMakeOutput.log". I tried to fix it with
sudo yum install spdlog
but it didn't help. Does anyone know how to fix it? Please excuse me if this is something very simple. I am quite new to openroad and Linux.
u

20Mhz

09/01/2021, 7:24 PM
First, are you sure is not there? How about doing:
find /usr/ -name "libspdlog*"
Else, maybe you can build it from here: https://github.com/gabime/spdlog
25 Views