https://open-source-silicon.dev logo
#openroad
Title
# openroad
s

Shivani

11/06/2021, 12:46 PM
Hello everyone, I going through this flow for an counter example: https://caravel-user-project.readthedocs.io/en/latest/ And now at the run full chip simulation step I am getting this error, Can anyone give me some hint on how can resolve?
m

Mitch Bailey

11/06/2021, 12:58 PM
@User For one, your
PDK_ROOT
doesn't appear to be set. Also running as
sudo
may be causing problems with the userid setting. Can you try this?
Copy code
export PDK_ROOT=$OPENLANE_ROOT/pdks
make verify-io_ports
s

Shivani

11/06/2021, 1:07 PM
Ya sure. Will try this out.
d

Dinesh A

11/07/2021, 2:00 PM
Apart from PDK_ROOT, look like there docker image installation issue .. Do you see efabless/dv_setup:latest in your docker image list ?
s

Shivani

11/08/2021, 7:01 AM
Yes PDK_ROOT is correct. there is some issue with volume permissions. Yes I see efabless/dv_setup:latest
m

Mitch Bailey

11/08/2021, 7:16 AM
@User You might try this If you have
CARAVEL_ROOT
set,
unset CARAVEL_ROOT
If you're executing in
caravel_user_project
, the
Makefile
will automatically set
CARAVEL_ROOT=$PWD/caravel
which is the default destination when you execute
make install
. The screen copy you sent seems to indicate that you've set
CARAVEL_ROOT=/caravel
. Is that what you intended?
s

Shivani

11/08/2021, 7:18 AM
Yes so I am inside caravel_user_project and running the RTL simulation. that is why I used this to go to caravel location that is pwd/caravel.
m

Mitch Bailey

11/08/2021, 7:27 AM
I may be misunderstanding you, but
/caravel
is not the same as
$PWD/caravel
. What do you get when you execute the following in
/home/lifam/Documents/shivani/caravel_user_project
?
Copy code
echo $CARAVEL_ROOT
ls $CARAVEL_ROOT
ls caravel
s

Shivani

11/08/2021, 7:38 AM
image.png
m

Mitch Bailey

11/08/2021, 7:43 AM
Looks good! (But I see you set
CARAVEL_ROOT
before executing) Try this
Copy code
unset CARAVEL_ROOT
make verify-io_ports
and let me know what you get.
s

Shivani

11/08/2021, 7:48 AM
So, I am following this
Copy code
export PDK_ROOT=<pdk-installation-path>
export CARAVEL_ROOT=$(pwd)/caravel
# specify simulation mode: RTL/GL
export SIM=RTL
# Run RTL simulation on IO ports testbench, make verify-io_ports
make verify-<testbench-name>
So, now without setting the 3 variables directly should I run make command?
going for lunch will get back in sometime. maybe you will see late reply!
m

Mitch Bailey

11/08/2021, 8:01 AM
You need to set
PDK_ROOT
and
SIM
but you need to replace
<pdk-installation-path>
with the path to your pdk installation. If you have
OPENLANE_ROOT
set correctly and the pdks are installed in the default location, you should be able to
export PDK_ROOT=$OPENLANE_ROOT/pdks
You can set
CARAVEL_ROOT
if you want, but the default will be set correctly in your case.
s

Shivani

11/08/2021, 11:28 AM
I don't see the
OPENLANE_ROOT
shoud be set in my case bcoz after running RTL simulation openlane comes in that document.
m

Mitch Bailey

11/08/2021, 11:53 AM
@User Ok, your setup is a bit different than what I've been using. Sorry for any misleading advice. The document you're referencing says you can either build native
make pdk
or non-native
make pdk-nonnative
, but I couldn't find the target for
pdk
in the
Makefile
. So you might try something like this
Copy code
export PDK_ROOT=/home/lifam/Documents/shivani/pdks
make pdk-nonnative
make verify-io_ports
The docker image you're using has openlane pre-installed, it seems.
s

Shivani

11/08/2021, 2:02 PM
yes it worked, thank you for your help.
👍 1